Are you using TLS older than 1.2?  It’s ok, maintenance update delays happen to everyone.  We get it.  However, it is time to move on.

Remember way back in June 2018 when we deprecated the use of TLS 1.0? If you don’t, that is okay, you can read all about it in this post.  Well, here we are, 2 years later and the next version is about to be sidelined so we want you to be prepared and avoid any interruption in service.  This post is all about getting you prepared to run without the use of TLS1.1 so we can restrict access to TLS1.2 only.  We will walk you through how to check your current version and how to upgrade to the latest.  Just for kicks, we’d really like to hear your feedback and add you to a “wall of awesomeness” featuring all those security-conscious companies who make the change early.

Does this affect me?

Back in 2018 we asked our customers to upgrade, and TLS 1.2 has been the recommendation for quite some time, so it is very likely that you are NOT affected.  However, if you use any method to inject messages (SMTP or REST API) or collect data (metrics or webhooks, etc), then you really should check now to make sure your system can support TLS 1.2.  Make sure you run the following tests on the servers that actually connect to SparkPost.  

Why it is important

  1. SparkPost will not accept connections on TLS 1.1 after September 2020
  2. Older versions are not secure
  3. TLS 1.2 has been the recommended protocol for over a decade
  4. All the cool kids are doing it
  5. IETF says it is officially deprecated

Why now?

Actually, the question should be “why are you still supporting it?”  TLS 1.2 has been the recommended secure standard for more than a decade and we are down to the wire on anyone actually offering any support at all for anything less than TLS1.2. It is time for weak HTTPS support to die once and for all.  If you are still using TLS 1.1 past March 2020 you are going to have a hard time connecting to most services.  SparkPost has provided ample grace to get this updated and now we are sending out final notices to get this upgraded before September when we kill it off for good.

But how, pray tell, can you fix it?

It is very possible that your IT SysAdmin or WebAdmin has done this already for you as part of their normal maintenance.  If so you should buy them a beer and say thank you.  If not you can follow some of the steps below to get it done in Linux, Windows, and Mac.

Note that throughout this document we will test with the US SparkPost end-point https://api.sparkpost.com/api/v1

If you normally use the European deployment, you should use the EU end-point instead.

https://api.eu.sparkpost.com/api/v1  

How can you check? (Linux version)

First, let’s check to see if your friendly neighborhood SysAdmin already took care of this for you. This is actually part of the SSL configuration so it can be managed in your system config.  Assuming you are using Linux, the most descriptive method is using nmap  but you can also use openssl.  You can use nmap with Linux, Windows and Mac, but we will explore other methods for Windows and Macs as well if you don’t want to install new software.

To do this with nmap, test the ciphers against a known HTTPS host.  Since the point is to make sure we are connecting to SparkPost securely, let’s test against that endpoint. Make sure you run the following tests on the servers that actually connect to SparkPost. 

This was done on my own development server and you can easily see my configuration supports TLS 1.1 and 1.2 but not 1.3.  It is important to note at this point that AWS ALBs, and therefore SparkPost connections, do not yet support TLS1.3, but it is on the AWS roadmap.

At this point, you can actually stop if you want because the point is to make sure you are able to connect to SparkPost using TLS 1.2.  If your connection supports TLS 1.2 that is what we need at this point so we are all good here.  Go buy that SysAdmin a beer and say thank you.

Send us an email and let us know you were successful.

Checking for support on your Mac

The most common reason you may need to check for support on your Mac is that you use it for local development, so let’s assume that and check for your support. 

The least invasive method is using curl which should be built into every Mac. Launch the Terminal application and use the protocol flag to test specifically for TLS1.2.

If you want to test using the SMTP connection, you can also do that with this command:

Returns a great deal of data including:

Checking for support in Windows

Similar to the Mac use case, the most common reason you may need to check for support in your Windows is that you use it for local development, so let’s assume that and check for your support. 

Windows 7 and Windows 10 use basically the same process.  If you are using something earlier, please upgrade as prior versions do not support TLS 1.2.

Start by clicking START in the bottom left corner (usually).

Type “Internet Options” and select the match from the resulting list.

Click on the Advanced tab and from there scroll down to the very bottom. If TLS 1.2 is checked you are already all set. If it is not, please check the box adjacent to Use TLS 1.2 and then Apply.

Wait, what? No 1.2? 

Bummer dude.  Your work is not done yet.

If you only have TLS1.1, then you should update your Cipher settings.

Assuming you are using Linux and Apache for TLS connection management, you can update the SSL configuration by modifying this line to add “ +TLSv1.2 ”:

SSLProtocol -all +TLSv1 +TLSv1.1 +TLSv1.2 

(Sidenote: Since they are not really supported anywhere anymore, it makes sense to also remove the 1.0 and 1.1 settings while you are in here.)

That config is typically located in /etc/httpd/conf.d/ssl.conf 

Restart Apache and you are good to go. 

service httpd restart

If you are using Nginx, you will want to modify this line in a similar way:
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;

That config is typically located in /etc/nginx/conf.d/ 

Restart Nginx and you are good to go. 

service nginx restart

If you run into any error messages with the restart, you may have an out-dated SSL library.  Make sure you are using at least openssl v1.0.1g.

If you are using Windows, the instructions for setting TLS1.2 are in the “Checking for support in Windows” section above.

All done now? Send us an email and let us know you were successful.

Going one step further

Why stop at TLS 1.2 when you know – you just know – that we are all going to have to upgrade to TLS 1.3 in the next year or so.  Why not just upgrade to TLSv1.3 while we are at it?

Unfortunately, AWS ALBs do not support TLS1.3 yet, so if you do upgrade your configuration, your connection to SparkPost and any other AWS service that uses the ALB layer will still be limited to TLS1.2. Personally, I still think it is a good idea to get ahead of the curve and upgrade to 1.3 while you are making changes anyway. 

If you want to add TLS 1.3 support you will probably have to update your OpenSSL library first to V1.1.1 or later and then add +TLSv1.3  to the protocol line mentioned above.  Similar instructions can be found here for Nginx and Cloudflare as well.

Stay safe out there

Finally, It would be great if you could drop us a quick email to let us know you have verified you are TLS 1.2 capable.  We really don’t want to cut anyone off and the drop-dead date is September 2020.  If we know you are all in the safe zone, we’ll feel much better about turning off the old support.

~ Tom